Book logo xindy

A Flexible Indexing System

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CFP: Source distribution of xindy


I have tried to follow the instructions for compiling xindy. Here
are my experiences after one afternoon:

My configuration:

	Sun 4/75
	SunOS 4.1.3_U1

- I got the files recommended in the WWW-page
  packages/xp.clisp.tar.gz seems not to be used anywhere.

- I have configured clisp to be made in a subdirectory.
  --with-dynamic-ffi seems to be added automatically. Maybe I should
  try it again without this configure option. I would guess that it
  works as well.

  The installation instructions indicate that -DIMMUTABLE is a good
  idea. This does not work for SunOS 4.*.

  make failed because libX11.a was not found. This is not contained in
  the X11R6.3 release where only the shared object is present. I have
  taken libX11.a from an X11R5 tree which I have also at hand.

  It takes really long to compile, test and install everything
  (serveral hours, even if everything works well) :-(

- I have compiled (once again) GNU Rx from the sources.

- The link recommended in the Web page does not work. rx is located in
  the directory rx-1.5.

- The link recommended in the Web page does not work because clisp.h
  is located in a subdirectory of CLISP and not of src -- because I
  have made clisp in a subdir.

- make -- even with fingerd crossed -- succeeded immediately. The
  Makefile triggers the target all which simply does nothing:-(
  the target `install' is unknown.

  I tried make in the rx subdirectory. This failed immediatly because
  the clisp script located there could not find the clisp

OK. That's it for today.

Maybe I need further instructions by mail as indicated on the Web